downloader quits before downloading (?)

May 1, 2012 at 7:05 PM
Edited May 1, 2012 at 7:07 PM

Hi there,

Just started having an issue where the application quits before it starts downloading anything and goes straight to the housekeeping.  The log doesn't seem to give any clues either, but I've attached it below anyway.  It doesn't even begin parsing the feed :\

http://pastebin.com/xhy2gxbg

Erm, any ideas?

 

 

 

Coordinator
May 2, 2012 at 5:06 PM

Not sure what is happening. IT doesn't seem that it is able to open the feed. I need to add more debugging in that area. When I added support for different feeds, I didn't add in sufficient debug output.

May 2, 2012 at 7:40 PM

Well I tried it again today and it worked.  Weird.

I definitely wasn't imagining it though because I tried it on two pcs and they both acted the same.  As you say, maybe it was the case that the feed wasn't available at that time or something.

Coordinator
May 3, 2012 at 6:12 AM

Glad the problem was temporary. I did add some addition debugging code to make sure we get an explaination of why it didn't download anything. Given the feed address, the program gets the number of items in the feed and processes each item one at a time. In your case, it appears that the query for the number of items in the feed was 0. This could be the result of a bad connection or a problem with the feed itself. In my case, I never notice it since I have HD-Trailers.Net Downloader set to run every day in the early hours. If it doesn't work on a given day, No problem it will work the next.

Take Care

May 3, 2012 at 6:35 PM

Cool, many thanks for the update and explanation.  I'll give it a go :)