Exception: Could not load file or assembly 'System.Web, Version=4.0.0.0

Mar 25, 2014 at 6:34 PM
When I attempt to run the program it flashes a command window for a few seconds and then closes. Looks like the errors are to blame, but no idea on how to fix.

Unhandled Exception....
3/25/2014 11:13:44 AM - Exception: Could not load file or assembly 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Log file

Config File
Coordinator
Mar 26, 2014 at 7:08 PM
Are you using an older version of visual studio? If so there may be a conflicting assemblies installed on your computer.
I haven't seen the error a web search for the error message point to a couple of items but nothing obvious.
Coordinator
Mar 26, 2014 at 7:20 PM
I can not replicate on my computers. If you don't have visual studio installed, could you try un update your .NET com;onents?
Apr 6, 2014 at 6:37 AM
Hello,
I just downloaded the latest version and I'm getting the same thing:
4/5/2014 11:31:01 PM - Next trailer: The Expendables 3 (Roll Call Trailer)
4/5/2014 11:31:01 PM - 
    480p       http://videos.hd-trailers.net/Expendables3_DomTrlr2-480p-HDTN.mp4
    720p       http://videos.hd-trailers.net/Expendables3_DomTrlr2-720p-HDTN.mp4
    1080p      http://videos.hd-trailers.net/Expendables3_DomTrlr2-1080p-HDTN.mp4
    poster     http://static.hd-trailers.net/images/cc8db170-bb51-11e3-89b9-ddb0799a8440_EX3_1Sht_Tsr_Stallone-resized.jpg

4/5/2014 11:31:01 PM - Looking up MovieName on IMDB
4/5/2014 11:31:01 PM - 1. Unhandled Exception....
4/5/2014 11:31:01 PM - Exception: Could not load file or assembly 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
This is running on Win 7 64bit Ultimate with .Net Framework 4 Client installed.
Coordinator
Apr 6, 2014 at 3:31 PM
Edited Apr 6, 2014 at 5:44 PM
I think I found it.
The installer is not checking for and installing, if needed, .net 4.0. Could you install .net 4.0 and try again.

The link for the .net 4.0 installer is
Microsoft .Net Framework 4.0

COuld you let me know if this solves the problem for you?
Apr 6, 2014 at 6:10 PM
That did the trick! Thanks!
Coordinator
Apr 6, 2014 at 7:23 PM
Edited Apr 6, 2014 at 8:43 PM
Thanks so much for confirming. I upgraded compilers which resulted a a change in version of .net that was required.

Now to figure out how to modify the installer so that it checks for the correct version of .net and downloads it if needed.
Apr 6, 2014 at 8:14 PM
I've run the the downloader a couple times now and it doesn't seem to close after it's done checking for trailers. This is after I downloaded .NET framework 4:
4/6/2014 1:10:18 PM - Next trailer: Lucy (Teaser Trailer)
4/6/2014 1:10:18 PM - 
    720p       http://www.hd-trailers.net/yahoo-redir.php?id=a98a8003-f052-368b-90f9-2448c04c8077&resolution=720
    1080p      http://www.hd-trailers.net/yahoo-redir.php?id=a98a8003-f052-368b-90f9-2448c04c8077&resolution=1080
    480p       http://videos.hd-trailers.net/lucy-tlr1_h480p.mov
    poster     http://static.hd-trailers.net/images/lucy-10763-poster-xlarge-resized.jpg

4/6/2014 1:10:18 PM - Looking up MovieName on IMDB
4/6/2014 1:10:23 PM - IMDB page was located
4/6/2014 1:10:23 PM - Config Specifies TrailersIdenticaltoTheatricalTrailers
4/6/2014 1:10:23 PM - Extracted download url (1080p): http://www.hd-trailers.net/yahoo-redir.php?id=a98a8003-f052-368b-90f9-2448c04c8077&resolution=1080
4/6/2014 1:10:23 PM - Local directory: M:\Trailers\Lucy (2013)
4/6/2014 1:10:23 PM - Filename : Lucy (Teaser Trailer).mov
4/6/2014 1:10:23 PM - Stream successfully opened
4/6/2014 1:10:23 PM - Invalid trailer size (-1 bytes) from Server. Skipping ...

4/6/2014 1:10:23 PM - Next trailer: The Raid 2 (Instant Commentary)
4/6/2014 1:10:23 PM - Title not a trailer. Skipping...

4/6/2014 1:10:23 PM - Housekeeping:

4/6/2014 1:10:23 PM - Serializing exclusion list...
4/6/2014 1:10:24 PM - Serialization complete.
4/6/2014 1:10:24 PM - Done
The DOS window just stays open - it never closes.
Coordinator
Apr 6, 2014 at 8:43 PM
Just set this key to false.
<!--disappearing before you can read it.-->
<add key="PauseWhenDone" value="true" />
Apr 7, 2014 at 3:03 PM
Thank you for replying ijourneaux!. Sorry but I never got an email notification that you had responded so quickly until the post from kuwaiticrud.

I checked and I did have .Net v4 installed. However, there were several updates pending, one of which is 4.5.1, so I applied them all. Everything seems to be working now!

I've attached screens shots of all updates applied in case you spot something else that might have effected it.

Image
Image
Image
Image
Coordinator
Apr 8, 2014 at 1:28 PM
I am trying to troubleshoot as we speak.
Coordinator
Apr 12, 2014 at 1:24 PM
Edited Apr 14, 2014 at 12:19 AM
The new installer used with 2.3.1 should resolve this issue.